Ruby 1.8.6